Instalar con composer en plesk

Instalar con composer en plesk

Tengo un servidor con panel de control plesk y necesito instalar una serie de paquetes de php con la instrucción composer install.

Al ejecutarla se muestra un mensaje de error como el siguiente

symfony/debug v4.4.10 requires php >=7.1.3 -> your php version (5.4.16) does not satisfy that requirement.

Se indica que la versión de php que estoy ejecutando para ejecutarlo está obsoleta, y necesito una  versión de php más actualizada , en mi caso la 7.2 como mínimo. Si no la tenemos instalada ya tenemos que ver como se hace esto, es porque el servidor plesk no estará actualizado.

El problema es que si ejecuto php -v para ver que versión estoy utilizando se muestra:

PHP 5.4.16 (cli) (built: Apr 1 2020 04:07:17)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

Con lo que efectivamente la versión que ejecuta php no es la correcta para mis necesidades.

¿Como se puede hacer esto sin fastidiar plesk? La idea principal es actualizar la versión de php, pero claro, me puedo cargar mil cosas del servidor y del panel.

La solución para ejecutarlo es la que escribo a continuación. Plesk , si está actualizado ya trae las nuevas versiones de php, por lo que para ejecutarlo dentro de la carpeta que necesitamos, en mi caso para una instalación de laravel, se debe llamar a la ruta completa tanto de php como de composer.

Sería algo así:

/opt/plesk/php/7.2/bin/php /usr/lib64/plesk-9.0/composer.phar install

En la que  /opt/plesk/php/7.2/bin/php  es la ruta a la versión de php 7.2

y /usr/lib64/plesk-9.0/composer.phar es la ruta a la ejecución de composer

Una vez lanzamos esta instrucción , ya comienza a instalar las dependencias que necesitamos y funciona todo correctamente.

 

 

Salir de la versión móvil